ubuntu14.04安装的phpmyadmin提示缺少mcrypt扩展

1.先检查是否又安装模块mcrypt:
    sudo apt-get install php5-mcrypt
2.检查/etc/php5/apache2/conf.d/和/etc/php5/mods-available/下是否又mcrypt.ini文件
如果/etc/php5/apache2/conf.d/下没有mcrypt.ini文件而/etc/php5/mods-available/下有,
则创建软链接:sudo ln -s /etc/php5/mods-available/mcrypt.ini /etc/php5/apache2/conf.d/
3.sudo service apache2 restart
4.重新打开phpmyadmin或者刷新。这样错误提示就没有了

Ubuntu 下安装 MentoHUST

1. 下载 MentoHUST :

免费下载地址在 http://linux.linuxidc.com/pub/2011/10/18/mentohust/

用户名与密码都是:www.linuxidc.com

2. 安装 MentoHUST :

$ sudo dpkg -i mentohust_0.3.4-1-2_i386.deb #后面的包是你选择下载 MentoHUST 的包

3. 设置本地的连接,新建一个有线连接,设置好 mac, ip, dns, gateway, netmask 等信息。有关于 802.1x 安全性的选项,勾选开启,并在校验方式里选择“MD5”,在下方输入你的锐捷认证的账号和密码即可。

4. 运行 MentoHUST

$ sudo mentohust

5. 根据提示配置好参数

Ubuntu Sublime 不支持中文的解决办法

首先跟着这个步骤来走:http://jingyan.baidu.com/article/f3ad7d0ff8731609c3345b3b.html

一旦执行到编译公共类库的时候: gcc -shared -o libsublime-imfix.so sublime_imfix.c  pkg-config --libs --cflags gtk+-2.0 -fPIC
出现: No package 'gtk+-2.0' found 的错误。

解决方法:

1. sudo apt-get install gtk+-2.0

2. 如果出现“无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系”的错误(如果不出现则忽略第3/4步)

3. 则打开 系统设置-软件更新-ubuntu软件 ,将“下载自”的选项从“中国服务器”改为“主服务器”。

4. 重新执行 sudo apt-get install gtk+-2.0

5.执行 gcc -shared -o libsublime-imfix.so sublime_imfix.c  pkg-config --libs --cflags gtk+-2.0 -fPIC

ubuntu安装flash player插件

每次装充装ubuntu系统后老忘记如何装flash player插件,这次先记下来。

搜索flash player,点击官网,选择.tar.gz格式。

浏览器会弹出下载界面,等待下载完成。下载完成以后的文件一般是在/tmp文件夹内,下载完成后在命令行界面用cd  /tmp命令转到tmp文件夹;

普通用户先用su – root命令转入超级用户模式,因为插件的安装涉及到更改权限问题。转入root用户后:输入下面4条命令(#号后面是注释)

tar -zx -f install_flash_player_11_linux.x86_64.tar.gz #解压下载好的压缩包

cp libflashplayer.so  /usr/lib64/mozilla/plugins       #复制插件到火狐浏览器插件文件夹

cd /usr/lib64/mozilla/plugins                            #定位到插件目录

chmod 755 libflashplayer.so                              #更改插件权限

然后就没有然后了。。。。。。点击测试一下吧

附上原文地址:linux下安装flash player.

PaaS 部署应用说明

跳了两次票,终于好了。不过发展壮大就看三位熊孩子了~

下面给出各种环境说明:

go 1.5 – 要求入口文件为 index.go ,需要监听 127.0.0.1:8000

python 2.7 – 要求入口文件为 index.py ,wsgi 函数的变量名为 app,需要提供 requirements.txt

python 3.5 – 要求入口文件为 index.py ,wsgi 函数的变量名为 app,需要提供 requirements.txt

继续阅读PaaS 部署应用说明